Close

World-Class Support

Posts in the Mask Pro 4 category:

How to access onOne Software through Photoshop Elements

Posted on June 1, 2011

Note: Perfect Layers is not available as a Photoshop Plug-in. This works as a plug-in for Adobe Photoshop Lightroom, Apple Aperture, or as a standalone application.

The following instructions show how to access onOne Software from Adobe Photoshop Elements.

Adobe Photoshop Elements (9 or 10)

There is only one way to access the onOne Software product(s) when using Adobe Photoshop Elements. Please make sure to open an image in ‘Edit’ mode and then go to File > Automation Tools. (this is not a video)

How to launch onOne Software products from Lightroom?

Posted on April 14, 2011

Perfect Layers can be accessed as a plug-in from inside of Adobe Photoshop Lightroom. You can find it in the File > Plug-In Extras menu.

  • If you select a single PSD file, the original file will be opened
  • If you select a single TIF, JPG or RAW file, a PSD copy with the Lightroom adjustments applied will be opened and will be stacked with the original image
  • If you select multiple files (PSD, TIF, JPG, RAW) PSD versions with Lightroom adjustments will be temporarily created and then merged into a new layered PSD file. The resulting file will be stacked with the first image in your Lightroom selection.
  • If an image is already open in Perfect Layers when you access it from the Lightroom plug-in you have the option of adding the selected images to the open image or closing the open image and creating a new one.

You will be able to control via a preference which bit depth and color space you prefer.

I am receiving an out of memory error

Posted on January 13, 2010

Below is a list of suggestions to help circumvent the memory errors

1.    Adjust PS Memory allocation to 75%

2.    Turn histories down to 4

3.    Close other applications, restart Photoshop

4.    Go straight to plug in

5.    Flatten the image to an 8bit

6.    Use early in workflow before upsizing

7.    If using a layered file, process only one layer

When the plug-in starts to process an image it will ask Photoshop for a single chunk of memory.  When memory gets fragmented this can prevent the plug-in from getting that single chunk of memory from Photoshop.  A restart of Photoshop can help clear up the fragmented memory.  You may want to do this if you’ve been heavily using Photoshop and then attempt to use the plug-in, especially on larger images, i.e. 80Mb or higher.

When launching Mask Pro a message comes up that says “Could not complete the Mask Pro 4.1 command because there is not enough memory (RAM)” – Macintosh Only

Posted on January 12, 2010

With version 4.1.6 there are some support files that might not be present on your Macintosh. Please make sure to download the latest version of Mask Pro from software updates. The software updates can by going to the Support Page and choosing a product on the right hand side. Once you have chosen a product, please scroll down to find the software updates.

Actions are not recorded when using the onOne Palette to launch a plug-in.

Posted on

This is a current limitation of the scripting language Photoshop uses with recording actions.  If you wish to record an action using an onOne plug-in, please record the action while launching the onOne Plug-In from the File->Automate menu (and not the onOne panel).

Please click here to view a video which illustrates how to create actions in Photoshop to batch process images using Perfect Photo Suite 6.

 

Is it possible to create clipping paths from masks created in Mask Pro?

Posted on January 13, 2009

If you used Mask Pro Select you are returned to Photoshop with a selection. Then go to Select->onOne->Mask Pro Make Work Path and try the default settings, this will create a path. Then go to the Path’s palette, select it and make it a clipping path.

If you used Mask Pro you are returned with no selection, but your subject will be on a transparent layer. Use the magic wand tool to click in the transparent area, which will select only the transparency, then invert the selection. Now you have a selection of just what you want, then go to Select->onOne->Mask Pro Make Work Path and try the default settings, this will create a path. Then go to the Path’s palette, select it and make it a clipping path.

There are some caveats to using clipping paths. They are a rather old technology that doesn’t understand transparency, it is just like cutting something out with a knife. This can yield hard edge transitions, what you would call helmet hair on people. Considering all modern page layout applications support native transparency in Photoshop files (InDesign CS2, CS3 XPress 6.5 and higher) which will give much better results if you just use Mask Pro to paint away to transparency. The only use for clipping paths today is if you wanted text to wrap to a curve, which can still easily accomplished by creating a hidden curve in the layout application, which is the better way to do it because you have more control and it is editable.

Work backwards in Mask Pro

Posted on

If you image is on a solid color background try using the apply all option with the magic brush tool. This will do 90% of the masking work in a single click. Then you can refine the mask by painting back in information that you want to save. Here is how.

Step One Open your image in Mask Pro 4

Step Two Use the drop eyedropper to select the background color. If the background is graduated try making two or three color samples one in the brightest area, one in the middle and one in the darkest area.

Step Three Double-click on the magic brush tool to apply to the entire image. This will paint away all of the background color.

Most of the time this will leave some small areas of the background or will remove some of our foreground. Use the regular brush set to remove or reveal to clean up these areas. You can check your mask quality by selecting the view mask mode by pressing 3 on your keyboard. Keep in mind this only works if your image has a solid background and the background color is not present in your foreground subject. This is great for chroma-key blue or green backgrounds.

Adjust Your Color & Tone First in Mask Pro

Posted on

Remember that Mask Pro 4 works based on color. If you image has a color-cast or is lacking contrast it can effect how well Mask Pro 4 works. You can often improve your masking results simply by doing your color-correcting and tonal adjustments before you use Mask Pro 4. Here is a quick way to get good results.

Step One With your image open, go to Image > Adjustments > Levels.

Step Two Click on the options button. Select Enhance Per Channel Contrast, enable the Snap Neutral Midtones check-box and set the highlight and shadow clipping to .10% If you don’t like the results try turning off the Snap Neutral Midtones option or using the Find Light and Dark Colors options.

Step Three Launch Mask Pro 4 and start masking

Why are some of the keep colors removed after I select keep and drop colors?

Posted on

One feature to look at is the threshold/tolerance sliders. These determine how much is taken away, try altering these sliders for better results or if you have lots of selections in the color palettes you may want to reduce the number of colors or make them into sets.

How do I get the color decontamination box enabled?

Posted on

Here are a couple options for enabling color decontamination:

1) Make sure to select both keep and drop colors.

2) Mask Pro can sometimes get into a state where that check box does not get activated. A workaround to get this to work again is to use the keyboard shortcut of cmd-d, on Windows it’s ctrl-d, to turn on color decontamination. This keyboard shortcut should toggle that option on/off.

3) Please make sure you have the target layer (layer to mask) selected in Photoshop. Please make sure a layer mask or alpha channel are NOT selected.